English | Lietuviškai

Info


Communication


PEROPESIS FORUM

This forum is dedicated to discussing issues related to the use and development of the Peropesis Linux operating system.

problem with apropos and whatis commands

by rosika, Saturday, November 19, 2022, 15:21 (8 days ago) @ g

Hi g, :-)

thank you so much for your new reply and all the time and effort you put into helping me.


I read your explanations and could follow them in my running instance of peropesis.
The second part of your post seems particularly interesting and I tried what you suggested.


I have to admit though that I didn´t make use of the text-editor ed in the past.
In fact I never knew it existed.


So I took a look at ed-command in order to get acquainted with it.
Still: your instructions are very good; I just wanted to know what I was typing...


So I changed line 66 of /etc/man_db.conf and commented out the respective entry:


#MANDB_MAP /usr/man /var/cache/man/fsstnd

After that I ran /usr/bin/mandb again and got the following output:


[...]
Updating index cache for path `/usr/share/man/man9´ . Wait...done.
Checking for stray cats under /usr/share/man...
Checking for stray cats under /var/cache/man...
9 man subdirectories contained newer manual pages.
461 manual pages were added.
0 stray cats were added.
0 old database entries were purged.


And after that: SUCCESS !!!


Both whatis and apropos commands are working.


So that´s the way to go...


Thank you very much for your help, g.


Many greetings from Rosika. :-)


Complete thread:

 RSS Feed of thread


Copyright © 2021 - 2022 Peropesis. See license terms.
E-mail: info(at)peropesis.org